USB_CAMERA_USB_CREATE_ERROR and shared library (Linux)

Published by belveder79 on

Home Forums Arducam USB Camera Shields USB_CAMERA_USB_CREATE_ERROR and shared library (Linux)

This topic contains 2 replies, has 2 voices, and was last updated by  bin 2 weeks ago.

  • Author
    Posts
  • #20368

    belveder79
    Participant

    I have a big framework in c++, which is basically controlled through nodejs. The framework has an NAPI interface which works flawlessly – it interfaces one shared library, which further pulls in other shared libraries – and one is actually a library to grab images from an AR0134 camera through an USB2.0RevD shield. I built that from the streaming example actually.

    If I use the shared grabber library through a standard executable, it works as expected. If I do dlopen/dlclose from another shared library it does not work (the Scan works, but the AutoOpen fails). I’m completely lost. All permissions are in place btw., sleep(2) as well. root does not work either… any ideas? thx

  • #20371

    belveder79
    Participant

    ok, nevermind, fixed it… the problem is that the handle (ArduCamHandle) needs to be a pointer, otherwise it can’t be accessed if passed around between the shared libraries…. (stupid me)…

  • #20377

    bin
    Keymaster

    Great to hear you have solved it. Let me know if you need more help.

     

You must be logged in to reply to this topic.