Trouble focusing the camera

Published by Mewit on

Tagged: 

  • This topic has 2 replies, 3 voices, and was last updated 2 months ago by bin.
Viewing 2 reply threads
  • Author
    Posts
    • #33626
      Mewit
      Participant

      1.Which seller did you purchase the product(s) from?
      UCTRONICS
      2.The Model number of the product(s) you have purchased?
      B0167B8 . It’s an IMX219 8 MP camera.
      3.Which Platform are you using the product(s) on?
      Raspberry 4B 8GB
      4.Which instruction are you following?
      Combination of things
      5.Has your product ever worked properly?
      Never got focused images.
      6.What problems are you experiencing?
      After you guys sent me a replacement motor control board, the servos all work now. However, the image that results is very out of focus, even after using the autofocus function in the focuserExample.py script. The image is so blurry that nothing can be made out. Do I have to make some manual adjustments to the lens before it will focus correctly?

      Here is an example picture:

      Thanks a lot,

      Alex
      7.What attempts at troubleshooting have you already made?
      Reset camera (R) and ran autofocus (ENTER) in the focuserExample.py script.
      8.How would you like us to help you?
      I am probably doing something stupid, but I don’t have much experience with this.

    • #34921
      DanielS
      Participant

      Hi @Mewit,

      I have exactly the same problem, have you been able to solve it ?

      please let me know if you were able to solve it.

      thanks.

    • #35271
      bin
      Keymaster

      Hi,

      Sometimes, you need to manually adjust the focal length of the lens, because the stroke of the motor is fixed and there is a certain focus range

Viewing 2 reply threads
  • You must be logged in to reply to this topic.