OV2640 camera module not working

Published by on

Home Forums Camera Breakout Boards OV2640 camera module not working

Viewing 4 reply threads
  • Author
    Posts
    • #21163
      Anonymous
      Inactive

      Hi. I have the OV2640 camera module, which I am hoping to eventually use with an FPGA to send RGB images over VGA. I’m currently testing it out just to make sure I’m using it right, and I haven’t been able to get any response out of it. When providing it with power/gnd, pulling reset and powerdown up/down as necessary, and providing it with a clock signal, the camera is not responding in anyway. I have a very similar camera module made with the OV7670 sensor, and it works perfectly when I do this. Any advice? Am I missing a setup step? Thanks so much.

    • #21221
      bin
      Keymaster

      Hi,

      The 0v2640 is different from 7670. For the ov2640, you should init it before getting image data.

      Please refer to our demo herehttps://github.com/ArduCAM/Arduino/tree/master/ArduCAM/examples/mini/ArduCAM_Mini_2MP_OV2640_functions

       

    • #21238
      Anonymous
      Inactive

      Thanks so much, this is really helpful! Quick follow up question: I’m running the code, and it’s not successfully writing to/reading from the registers in the first step. I’m guessing this is because I don’t have the wires hooked up correctly, but before I get too far in, I wanted to confirm whether or not these steps should work without the Arduino shield? I didn’t get the shield because I’m planning to feed the output data into an FPGA, and I’m just using an Arduino right now to understand how to get the camera set up. Should this approach work, or would it work with minor modifications to the code?

    • #21449
      Anonymous
      Inactive

      Hi…I tried the same program on the same ESP, just changed the camera module with OV2640 (version AF2569) and it worked OK.My question is does the PINS should be differently specified for the OV2640 (version XRZ00D1) ?
      Also physically these two cameras (XRZ00D1 and AF2569 ) look slightly different.

    • #21987
      bin
      Keymaster

      Hello,

      Sorry for my late reply, I am too busy recently.

      Q1: I wanted to confirm whether or not these steps should work without the Arduino shield?

      A1: The plan you mentioned is feasible. However, our current design does not connect the i2c signal to fpga. So, you must use other master controller init the camera through the i2c bus.

      Q2:My question is does the PINS should be differently specified for the OV2640 (version XRZ00D1) ?
      Also physically these two cameras (XRZ00D1 and AF2569 ) look slightly different.

      A2: Would you like to attach me some pictures about the two version you mentioned?

Viewing 4 reply threads
  • You must be logged in to reply to this topic.