How to make Arducam OV5642 SPI Camera module work on ESP32-WROOM-32U

Published by Margarito Lehmann on

Home Forums Arducam SPI Cameras How to make Arducam OV5642 SPI Camera module work on ESP32-WROOM-32U

Viewing 5 reply threads
  • Author
    Posts
    • #24643
      Margarito Lehmann
      Participant

      I am having trouble hooking up the Arducam OV5642 which is technically an Arduino camera to the ESP32-WROOM-32U. The ESP-32 has SPI and I2C interface so I am assuming if I hardwire the connections it should still work. However, when I connect the wires and run the Arducam_ESP32_Capture sketch, the serial monitor at 115200 baud prints out an infinite loop with this message.
      rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT) configsip: 0, SPIWP:0xee clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00 mode:DIO, clock div:1 load:0x3fff0018,len:4 load:0x00000000,len:131072
      What could be the error?

      Attached you could check my hardware connections.

    • #24665
      Arducam jyh
      Moderator

      Hi,

      Please refer to this link first.

      If there is still a problem, it could be a hardware problem, make sure the board is fine.

    • #24676
      Arducam jyh
      Moderator

      I have seen the picture of your board, it doesn’t seem to be ESP32, please confirm the specific type of chip you are using.

    • #24675
      Margarito Lehmann
      Participant

    • #24677
      calvinlee
      Participant

      Sorry this was originally an email to the support team and the second reply was not posted. Here it is.

      Hi, we have decided to change our board to the Arduino Nano. We were able to successfully use the Arduino Uno with the example sketch code provided by the Arducam github, but when we connected the Nano, we could not get past the “COM Open!” on the ArduCAM_Host_V2.exe application. The example sketch “ArduCAM_Mini_5MP_OV5642_Plus_Functions” is able to be uploaded successfully. Screenshots are attached. Any help would be appreciated.

    • #24697
      Arducam jyh
      Moderator

      Hi,

      Make sure you select the correct development board and successfully upload the example. If ‘COM is open’ can not get pass, try pressing the reset button on the board.

Viewing 5 reply threads
  • You must be logged in to reply to this topic.