getting weired images

Published by greentube on

Viewing 9 reply threads
  • Author
    Posts
    • #22137
      greentube
      Participant

      I’m trying to take stereo images. when I choose mode 12 i get wrong images like in the attached file.

      Mode 11 doesn’t even start. Modes from 7 to 10 work but they don’t have the full FOV.

      I am using RPI 4B

      What I’m doing wrong?

      Any help is appreciatedphoto

    • #22157
      bin
      Keymaster

      Hi,

      Don’t worry and  I will try my best to help you. Please tell me what the sensor type you are using. It seems the clock speed is too fast  and maybe I  should help you optimize the sensor configuration.

       

    • #22263
      greentube
      Participant

      Thnak you!

      I’m using the “standard” 8MP IMX219 Sonsor

    • #22270
      bin
      Keymaster

      Hi,

      Thanks for your detail information. I will test it tomorrow.

      You can try to increase the value of the 0x0162 register.

      You can use the API int arducam_write_sensor_reg(CAMERA_INSTANCE camera_instance, uint16_t address, uint16_t value); to write the register.

       

    • #22290
      bin
      Keymaster

      Hi,

      Have you tested it as I suggested? I am too busy to test it today. Thanks for your patient.

    • #22329
      greentube
      Participant

      Hi,

      No problem if it takes a few days 😉

      Can you give me a little bit more information what exactly i have to do,… I’m not that pro in programming and i don’t want to do anything wrong.

      Thanks

       

    • #22387
      bin
      Keymaster

      Hello,

      Sorry to reply you late. I have optimize our code for imx219 mode 11 and 12. Please download our new library and try it again.

      Just following the steps to update your lib

      sudo rm -R MIPI_Camera

      git clone https://github.com/ArduCAM/MIPI_Camera.git

      cd MIPI_Camera/RPI

      sudo make install

      Then retry it again.

      Notice, because mipi is a high speed signal, your connection should not be too long, which has a certain influence on the signal

      Let me know if you need more help.

       

    • #22505
      greentube
      Participant

      Great, now it works!

      Other question: How can I manually change the White Balance?

      When AWB is disabled any changes like in Link  seem to have no effect to the image.

      Appreciate the help!

       

    • #22521
      greentube
      Participant

      Great, now it works!

      Other question: How can I manually change the White Balance?

      When AWB is disabled any changes like in Link  seem to have no effect to the image.

      Appreciate the help!

    • #22543
      bin
      Keymaster

      Hi,

      Great to hear it works.

      For the awb, due to without official hardware ISP support, arducam now uses general software white balance algorithm and it didn’t work very well. To solved it, we provide a compensation way. After run arducamstill, you can use key board to fine tune the image, but you should enable

      the awb, because we will add software compensation on awb.

      You can refer to this topic to get more detail information https://www.arducam.com/forums/topic/how-to-fine-tune-the-arducam-mipi-camera-image-quality-manually/

       

Viewing 9 reply threads
  • You must be logged in to reply to this topic.