Home Forums Search Search Results for 'green'

Viewing 15 results - 1 through 15 (of 30 total)
  • Author
    Search Results
  • #25778

    still green



    It is due to we don’t have awb. The image looks green, which  will not affect the algorithm calculation



    The green led  means the data from sensor to stereo hat is not stable.

    Please attach me your hardware connection and I will help you check it in detail.


    when I run 1_test.py I still got the green frame, I don’t know why, and try several times but still green. 




    When I use following command for setup testing, the images are normal color.

    raspistill -t 0 -p 800,100,1024,768


    But, When I do the 1_test.py at the “Depth Mapping on Arducam Stereo Camera HAT with OpenCV” , I got all the green images. I don’t know this is the fault h/w or s/w setting, anyway, after next step 2_chess_cycle.py, 3_pairs_cut.py, at 4_calibration.py step could not finished.


    Is this related the green color problem?

    Please help me find the solution.



    I have reinstalled Raspbians on my both RPis. On both I have installed Raspbian GNU/Linux 10 (buster) and followed this readme.


    I set GPU memory to 250.

    • Rpi 4 4GB

    On this model I could not get “good” image in full res. (4656 × 3496). Images are full of random noise with pink and green stripes. There is no difference between using c++ or python examples. I was turning awb on, off ect. No change there.

    On lower resolutions everything works fine. Unfortunately I was really counting on full res on RPi4. I was hoping to get 4x 16MP cameras and connect them through ArduCAM multiplexer to RPi. I do not care about stereo, but I need 16MP+

    • Rpi3 b+

    On this model camera seems to work fine. I can get full res images, manual white balance works as well as focus and everything else. However very rarely I got images with random pink stripes but it was only 1 or 2 and I did 150+ still images.


    I have checked both RPis with different cameras. I used 5MP, 8MP and everything works fine so I think there is nothing wrong with RPis.

    Could you please take a look on that? I am afraid this kind of problem is way above my skills. It looks a bit like there might be just to much data for RPi to read from sensor.



    I got a second so I have connected camera to RPi3.

    I can take an image in full res and it does not have easily visible stripes but i can see on image there are some artifacts like black horizontal line.

    Also images I am having are green. AWB does not work at all now.

    When I am executing preview.py I am having error:

    mmal: Failed to set black level – try updating firmware

    Is it possible that I have damaged sensor when executing script with manual gains? It was working when I was using c++ so I have no idea what happened here.



    I have followed every step in readme.md so yes. I did everything including installing .so file.

    Right now my concern is that I can not get an image in full resolution without green and pink stripes. I will try to test it on different RPI and let you know how it looks like.



    The green oil I said is solder mask.



    It works in principle. But welding is difficult. You should remove one board’s crystal oscillator.

    For the other board, our crystal oscillator signal is not easy to operate under.

    You need to scrape a little of the green oil off the perimeter to expose the signal for welding


    Let me know if you need more help.




    Hi Bin,

    I have added auto-exposure and auto white balance along with a time delay of 0.01 seconds within the function “def get_frame (camera):”, within the stereo_depth_demo samples provided, as the first think the program does. So it works, it is a little bit red but that’s a smaller issue than a completely green image.

    Am I correct that I would need to add the auto white balance to all of the source files that are capturing an image?

    How do I correct for the image coming upside down on screen?

    I am still unable to run the simple examples in ~/MIPI_Camera/RPI such as “preview-dualcam” and “capture-dualcam” , I get the text “Open camera… , init camera status = 4100, open camera, init camera status = 4100” and then it exits the program.

    • This reply was modified 2 months, 4 weeks ago by sahil.

    Thanks, Bin.  I got most of the above to work.  I am still dealing with a green screen when i run all the demo python scripts which seems to be affecting the calibration?  I can tune the color and brightness of the screen using ./arducamstill -t 0 but then when i run python 1_test.py it shows up as green.  I found your post here which seems like a potential solution:


    However which exact file (name and file extension) do I need to update in order to do that.  If it’s a .c file, how would you compile the c code using the command line?

    when  i run the 4_calibration.py file, it ignores all of my 30 images.

    I look forward to hearing from you.






    The arducamstill supports for online debugging, will revert to the default value after exit.

    So when you exit the arducamstill and run the python demo, it will user the default value.

    I advise you using arducamstill to fine tune the image, then remember the value of each parameters. Each parameter’s value will display as the below image shows.

    Then you can use the set_control API to set the suitable values referring the images I attached for you:

    About the image is green, have you enable the awb function?

    Referring code:

    print(“Enable Auto White Balance…”)
    camera.software_auto_white_balance(enable = True)


    Let me know if you need more help.



    Thanks, Bin.  I am still getting a green screen when I run python 1_test.py.  I played with ./arducamstill -t 0 and was able to tune the color brightness and focus.  However, when I run 1_test.py, it goes back to green.

    I saw in another post that you changed the register values or the set mode?  Which exact file would you make those changes to and if the file is a c file, do you need to compile after?  How would you compile that file on the command line?

    Also, when i run 4_calibration.py, it ignores all 30 of my images.  I am assuming because too dark and green?




    Hi Bin, Thank you very much for making that table.

    So do you think i should be able to run the stereo depth demos without updated lens shading table?

    I have tested 1_test.py again just now and again the image is upside down and green, I can only run mode 7 to 10 anything higher I get “Null Pointer Access”.  In addition i am not able to run 2_chess_cycle.py and get the error below still.

    [email protected]:~/MIPI_Camera/RPI/stereo_depth_demo $ python 2_chess_cycle.py
    Open camera…
    Found sensor imx219 at address 10
    Can’t open the file
    mmal: Failed to fix lens shading, use the default mode!
    Current mode: 2,resolution: 1600×1200
    Used camera resolution: 1600 x 1200
    Scaled image resolution: 1280 x 480
    Starting photo sequence
    Traceback (most recent call last):
    File “2_chess_cycle.py”, line 88, in <module>
    frame = get_frame(camera)
    File “2_chess_cycle.py”, line 44, in get_frame
    image = frame.as_array.reshape(int(height * 1.5), width)
    File “/home/pi/MIPI_Camera/RPI/stereo_depth_demo/arducam_mipicamera.py”, line 266, in as_array
    return np.ctypeslib.as_array(self.buffer_ptr[0].data, shape=(self.length,))
    ValueError: NULL pointer access

    and then

    [email protected]:~/MIPI_Camera/RPI/stereo_depth_demo $ python 3_pairs_cut.py
    No file named ./scenes/scene_1280x480_1.png
    No file named ./scenes/scene_1280x480_2.png
    No file named ./scenes/scene_1280x480_3.png
    No file named ./scenes/scene_1280x480_4.png
    No file named ./scenes/scene_1280x480_5.png
    No file named ./scenes/scene_1280x480_6.png
    No file named ./scenes/scene_1280x480_7.png
    No file named ./scenes/scene_1280x480_8.png
    No file named ./scenes/scene_1280x480_9.png
    No file named ./scenes/scene_1280x480_10.png
    No file named ./scenes/scene_1280x480_11.png
    No file named ./scenes/scene_1280x480_12.png
    No file named ./scenes/scene_1280x480_13.png
    No file named ./scenes/scene_1280x480_14.png
    No file named ./scenes/scene_1280x480_15.png
    No file named ./scenes/scene_1280x480_16.png
    No file named ./scenes/scene_1280x480_17.png
    No file named ./scenes/scene_1280x480_18.png
    No file named ./scenes/scene_1280x480_19.png
    No file named ./scenes/scene_1280x480_20.png
    No file named ./scenes/scene_1280x480_21.png
    No file named ./scenes/scene_1280x480_22.png
    No file named ./scenes/scene_1280x480_23.png
    No file named ./scenes/scene_1280x480_24.png
    No file named ./scenes/scene_1280x480_25.png
    No file named ./scenes/scene_1280x480_26.png
    No file named ./scenes/scene_1280x480_27.png
    No file named ./scenes/scene_1280x480_28.png
    No file named ./scenes/scene_1280x480_29.png
    No file named ./scenes/scene_1280x480_30.png
    End cycle


Viewing 15 results - 1 through 15 (of 30 total)