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1 Introduction

Arducam now released a ESP32 based Arduino board for Arducam mini camera
modules while keeping the same form of factors and pinout as the standard Arduino
UNO R3 board. The high light this ESP32 board is that it well mates with Arducam
mini 2MP and 5MP camera modules, supports Lithium battery power supply and
recharging and with build in SD card slot. It can be an ideal solution for home

security and loT camera applications.

Figure 1 Arducam ESP32 UNO Kit

Features

Build in ESP-32S Module

26 digital input/output pins, 10 ports are 3.3V tolerant
Arducam Mini 2MP/5MP camera interface

Lithium battery recharging 3.7V/500mA max
Building in SD/TF card socket

7-12V power jack input

Build in micro USB-Serial interface

vV V. ¥V ¥V VYV V VYV Vv N

Compatible with Arduino IDE
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3 Pin Definition
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Figure 2 Arducam ESP32 UNO Pin Out
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The board has build in Lithium battery charger, which accepts default

3.7V/500mA Lithium battery. The charging indicator and charging current setting can

be found from the Figure 3.

Lithium
battery
socket

»ame pone ESPI2S UND |
[CR ) 1

SD indicator

Lithium battery
charge indicator(1)
Lithium battery
charging completed
indicator (1)

Rprog Current Setting (2)
Factory-installed 2.2K
500mA current

(Mindicator light state Rprog Current Setting

BHiakds Bls YellﬂED GreﬂED RrROG Igar

CHRG oTDBY (k) (mA)

charging bright extinguish 10 130

Charge Termination | extinguish bright 5 250

Vin too low; 4 300

Temperature of 3 400

battery too low or extinguish extinguish 5 550
too high;

no battery 1.66 690

1.5 780

?gjg;’:aiﬁz::: Greed LED bright, Yellow = -

’ LED Coruscate T=1-4 S
No battery 1.2 1000

Figure 3 Battery Charging Indicator and Current Settings
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4 Getting Started ESP32 with Arduino IDE

This chapter shows you how to develop an application for Arducam ESP32 UNO
board using Arduino IDE. (Tested on 32 and 64 bit Windows 10 machines)
4.1 Steps to install Arducam ESP32 support on Windows
» Starting Download and install the latest Arduino IDE Windows Installer from
arduino.cc
Download and install Git from git-scm.com

Start Git GUI and run through the following steps:
Select Clone Existing Repository:

& GitGui - O *

Repository Help

Create New Repository

ICIone Existing Regositog

Cpen Existing Repository

Quit

Figure 4 Select Clone Existing Repository
Select source and destination:
Source Location: https://github.com/ArduCAM/ArduCAM_ESP32S_UNO.git
Target Directory: C:/Users/[YOUR_USER_NAME]/Documents/Arduino/hardware/
ArduCAM/ArduCAM_ESP32S_UNO

Click Clone to start cloning the repository:

& GitGui o X

Repository Help

Clone Existing Repository
Source Location: ‘https:llgilhub.com,’ArduCAM/ArduCAM_ESP325_UNO.gi: Browse
Target Directoryt}C:IUsers,"J inistrator/Doc ts/Arduino/hardware/Ardut  Browse
- Clone Type: Standard (Fast, Semi-Redundant, Hardlinks)

Full Copy (Slower, Redundant Backup)

Shared (Fastest, Not Recommended, No Backup)

Clone Quit

[ Recursively clone submodules too!

Figure 5 Clone the Repository
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Open C:/Users/[YOUR_USER_NAME]/Documents/Arduino/hardware/

ArduCAM/esp32/tools and double-click get.exe

o Arduing » hardware » ArduCAM > ArdwCAM_ESP32S UNO » tools 2 ﬁE%C:\Users\zklDQ\Documents\Arduina\hardware\ArduCAM'\Ar’duCAM_E5P325_UNO\tuo|s\getexe

2 platfermio- bulld py

Figure 6 Install ESP32 board

When get.exe finishes, you should see the following files in the directory

<« Arduino » hardware » ArduCAM > ArduCAM _ESP325 UNO > tools v |0 #="tool.. L
A oz - ez = +
dist
partitions
sdk
xtensa-esp32-elf
2 build.py

[E] common.sh
A espota.exe

2 espota.py

B esptol.exe

# esptool.py

A gen_esp32part.exe
2 gen_esp32part.py
A getexe

= getpy

2 platformio-build.py

Figure 7 ESP32 board directory

» Plug your ESP32 board and wait for the drivers to install (or install manually

any that might be required)
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4.2 Using Arduino IDE

After installation of Arducam ESP32UNO board, you can select this board from
the Tool->Board menu. And there several ready to use examples from the
File->Examples->ArduCAM. You can use these examples directly or as a starting
point to develop your own code.

» Start Arduino IDE, Select your board in Tools > Board menu>

&9 sketch_jul17b | Arduine 1.8.0 - m] e
File Edit Sketch Tools Help

oo 1 Auto Format Ctrl+T E
Archive Sketch
sketch_jult7h Fix Encoding & Reload =
vold setup() Serial Monitor Ctrl+5Shift+ M 2

// pur youl  Serial Plotter Corl +Shift+ L

WiFi101 Firmware Updater

}

Board: "ArduCAM ESP32S UNO"
Flash Frequency: "80MHz"
void loop() Upload Speed: "a21600"

// put youl Port: "COMS"
Get Board Info

Vo v v

Programmer: "ArduinolSP" >

Burn Bootloader

Figure 8 Board Selection
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» Select the example from File->Examples->ArduCAM

@' sketch jul17a | Arduinc 1.8.3 D53231 )
File Edit Sketch Tools Help Ethernet 3
MNew Ctrl+M Firmata >
Open... Ctrl+0O Humiina »
Open Recent : ILI9486 Test »
Sketchboolk 3 ITEADLIB_Arduino_ESPB266-master > |*
Examples 3 Keypad *
Close Ctrl+W LCD_1602 RUS »
Save Ctrl+5 LedControl >
Save As... Ctrl+Shift+5 LiquidCrystal ?
) LiquidCrystal_12C »
Page Setup  Ctrl+Shift+P L.
LiquidCrystal 12C-master 1
Print Ctrl+P
MPUB0DS0 »
Preferences Ctrl+Comma MNewPing >
. sD ¥
Quit Ctrl+Q
S11143_Pulse_Prox_Sensors >
SoftSPl »
Stepper »
Temboo 3|
TFT > I
. . . . Usglib »
[nvalid library found in g I ~
. . . WiFi >
[nvalid libr ound 1n
[nvalid 1ibr ound in Examples for ArduCAM ESP325 UNO
ArduCAM 3 ESP32 ArduCAM _ESP32 Capture
Arducam_ESP32 TVOC »[7 ArduCAM_ESP32_Capture2SD
ArducamS5D1306 ] ArduCAM ESP32 Sleep
ArduinoOTA » ArduCAM_ESP32 Video?2SD

Figure 6 Example Selection
» Configure the camera setting
You need to modify the memorysaver.h file in order to enable OV2640 or
OV5642 camera for ArduCAM Mini 2MP or 5MP camera modules. Only one
camera can be enabled at a time. The memorysaver.h file is located at
C:\Users\Your computer\Documents\Arduino\hardware\ ArduCAM

\ArduCAM_ESP32S_UNO\libraries\ArduCAM

//5tep 1: select the hardware platform, only one at a time
Edetine OvZed0o Mint omp |

//#define OV5642 MINI S5MP

//#define OV5642 MINI S5MP BIT ROTATION FIXED

//#define OV5642 MINI SMP PLUS

//#define OV5640 MINI SMP PLUS

//#define ARDUCEM SHIELD REVC
//#define ARDUCAM SHIELD V2
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Figure 7 Camera Configuration
» Compile and uploading
Click uploading the example will automatically flashed into the board.
4.3 Examples
There are 4 examples for both 2MP and 5MP ArduCAM mini camera modules.
» ArduCAM_ESP32_ Capture
This example uses HTTP protocol to capture still or video over home wifi
network from ArduCAM mini 2MP/5MP and display on the web browser.
The default is AP mode, after uploading the demo, you can search the
‘arducam_esp32’and connect it without password.

9 ArduCAM ESP32 Capture | Arduino 1.8.3 — O >
File Edit Sketch Tools Help

ArduCAM_ESP3Z_Capture

J/Default is AP mode. =
int wifiType = 1; // 0:5tation 1:AP

/AP mode configuration

J/Default is arducam espR266. If vou want, vou can change the AP aalid to vour f
const char *AP ssid = "arducam esp32”;
//Default is no password. If vou want to set password, put vour password here

const char *AP password = NILL:

//5tation mode vou should put vour ssid and password
const char *ssid = “S5ID”; // Put vour 55ID here
const char *password = "PASSWORD”: // Put your PASSWORD here

Figure 8 Mode Configure
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€9 comg - O X

Send

1k drv:0x00, g drv:0x00, d_drv:0=x00, cs0_drv:0=x00, hd_drv:0=z00, wp_drv:0x “
node:DI0, clock div:l

Load:0x3fff0008, len: 8

Load:0x3f££f0010, 1en: 20156

Load:0x40078000, len: 7780

10 0 tail 12 room 4

Load:0x40080000, len: 252

antry 0x40050034

irduCAN Start!

V2640 detected.

share AP: arducam esp3Z2

[he password is: ‘\
192, 1658. 4. 1 \
server started

< >

[] futoserall Mo line ending = | 115200 baud - Clear output

Figure9 Identifying IP address

If you want to use STA mode, you should change “int wifiType = 1’ to ‘“int

wifiType =0".Tthe ssid and password should be modifies before uploading.
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€8 ArduCAM ESP32 Capture | Arduino 1.8.3 — O et
file Edit Sketch Tools Help

ArduCAM_ESP3Z_Capture §

Fendif

//vou can change the value of wifiTvpe to select Station or AP mode.
J/Default is AP mode.
int wifiType = 0f // 0:Station 1:AP

//AP mode configuration

[//Default is arducam_esp8266. If vou want, vou can change the AP_aaid to -
const char *#AP ssid = "arducam esp32”;

//Default is no password. If vou want to set password, put vour password h

const char *AP password = NILL;

//Station mode vou should put vour ssid and password
Fonst char *ssid = "SSID”; // Put vour SSID here
-onst char *password = "PASSWORD”: // Put vour PASSWORD here

Figure10 Wifi Camera Example
After uploading, the board IP address is obtained via DHCP protocol. You can
figure out the IP address through the serial monitor as Figure 9 shown. The default

serial monitor baudrate setting is 115200bps.
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& coms - 0o X
| et ]
rdi | EH 1 <l H o ool o sRllLL4E LB s o Rl 1510

V2640 detected ‘_‘-‘

Connecting to 3A0F1F1-10327F

.. .WiFi comnected

192.168.0.3

Berver started

T N

]
Autoscro].l "~ llo line ending | 115200 ha§g

Figure 10 Identifying IP address

Finally, open the index.html , input the IP address obtained from the serial

monitor then take pictures or videos. The html files are located at

C:\Users\Your computer\Documents\Arduino\hardware\ArduCAM\ArduCAM_ESP32S_UNO

\libraries\ArduCAM\examples\ESP32\ArduCAM_ESP32_Capture\html

ArduCAM_OV2640 Video

Camera IP Address

192.168.4.1

160X120 176X144 320%240 352X288 640X480
B800X600 1024X768 1280X1024 1600X1200

Figure 11 Example Html page
» ArduCAM_ESP32_Capture2SD
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This example takes time elapse still photos using ArduCAM mini 2MP/5MP
and then stored on the TF/SD card. The LED indicates when the TF/SD card is
writing.
€ como - O ¥

Send

load:0x3fff0008, len: 8
load:0x3f£f£0010, len:2016
load:0x40078000, len: 7780
ho 0 tail 12 room 4
load:0x40080000, len: 252
entry 0x40080034
ArduCAN Start!

SD Card detected!

5D Card Tvpe: SDHC

SD Card Size: TS80MB
OV2640 detected.

Star Capture

Capture Done.

The fifo length 1s :6148
Image save OK.

Star Capture

Capture Done.

The fifo length is :6148 o
< >

[+] tutoserall Mo line ending | |115200 baud - Clear output

Figure 12 Example ArduCAM_ESP32_Capture2SD

» ArduCAM_ESP32_Video2SD

This example takes motion JPEG video clips using ArduCAM mini 2MP/5MP and
then stored on the TF/SD card as AVI format.
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€9 coms - O X

| Send

configsip: 0, SPIWF:0xz00
cllk drv:0x00, q drv:0=x00, d_drv:0x00, c=0 _drv:0=x00, hd_drv:0=z00, wp_drv:0x
mode:DI0, clock div:l

load:Q0x3f££f0008, len: 8

load:0x3£f££f0010, len: 2016

load:0x40078000, len: 7780

ho 0 tail 12 room 4

load:0x40080000, len: 252

entry 0x40080034
ArduCAN Start!

5D Card detected!
V2040 detected,
5D Card Tvpe: SDHC
5D Card Size: T580MB

ecording video, please wailt...

Flecord video CE

Recording video, please walt...

< >

[+] Autoserall Wo line ending + | |115200 baud - Clear output

Figure 13 Example ArduCAM_ESP32_ Video2SD
» ArduCAM_ESP32 Sleep
To reduce power consumption,calling the interface function immediately goes into the
Deep - sleep mode.In this mode, the chip will disconnect all wi-fi connections and
data connections and enter the sleep mode. Only the RTC module will still work and

be responsible for the timing of the chip. This demo is suitable for battery power
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Figure 14 Normal mode

Figure 15 DeepSleep mode

15 www.ArduCAM.com



Ardu@am Arducam ESP32 UNO Board User Guide

SD Card detected!

3D Card Type: SDHC

5D Card Size: 7580MB
V2640 detected.

Star Capture

Capture Done.

The fifo length 1s :717Z
Image =save QE.

ets Jun 8 2016 00:22:57

rst:0x5 (DEEPSLEEP_RESET), boot:0x13 (SPI_FAST_FLASH BOOT)

configsip: 0, SPIWP:0=00

cllk drv:0z00, g drv:0z00, d derv:0z00, cs0_drv:0x00, hd_drv:0=z00, wp_drv:0x
mode:DIO, clock div:l

load:0x3f££0008, len: 8

load:0x3f££0010, len: 2016

1oad:0x40078000, len: 7780

ho O tail 12 room 4
< >

Figure 16 Example ArduCAM_ESP32_Sleep
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